Tag Archives: ruby

Segmentation Fault when installing Janus

If you use vim, and haven’t seen Janus yet, I suggest you take a look at this project from the carlhuda team.

If you decide to install Janus, and have no problems, you will likely never see read this post. If, however, you do run into the ‘segmentation fault’ error, here is the cure for what ails you.

> sudo apt-get install ruby ruby-dev

Thats right, you didn’t read the the fairly comprehensive README carefully, and had no system ruby installed, which broke the Command-T installation, and simply installing ruby and ruby-dev (for mkmf), will allow the installation to complete successfully. You may also need to install the exuberant-ctags packages for ctags support. but not doing so will not break the installation.

Good luck.